FIP - NA Multi Tenant 1 performance issues

Incident Report for Clarivate

Resolved

The service has remained stable, and we have not received any new user reports during the monitoring period.

This is the final notification for this incident and the issue stands resolved.
Posted Dec 18, 2025 - 18:04 UTC

Monitoring

We investigated an issue where FIP Main (FoundationIP – NA – Multi-tenant 1) customers reported slowness while accessing the application, with navigation between matters taking approximately 28 seconds.

The technical teams have taken corrective actions to address the underlying cause of the issue, and as a result, the service has been functioning as expected since 13:52 UTC.

We’ll continue to monitor the services for stability and will share the next update by Thursday, December 18, 2025, at 18:15 UTC, early as events warrant.
Posted Dec 18, 2025 - 14:21 UTC
This incident affected: FoundationIP (FoundationIP - NA - Multi-tenant 1).