IP Collaboration HUB - Billing Module outage

Incident Report for Clarivate

Resolved

We have implemented the corrective measures to resolve the underlying cause of the issue.
The functionality has been restored and is working as expected now.

This is the final notification for this incident and the issue stands resolved.
Posted Jan 13, 2026 - 13:01 UTC

Investigating

IP Collaboration HUB users are unable to access the Billing Module in the application.

We are working to remediate the underlying cause of the issue.

We'll share the next update by Tuesday, January 13, 2026, at 12:00 UTC
Posted Jan 13, 2026 - 10:00 UTC
This incident affected: IP Collaboration Hub.