The service has remained stable during our extensive monitoring period. No additional user reports have been received.
This is the final notification for this incident and the issue stands resolved.
Posted Dec 19, 2025 - 15:17 UTC
Update
Following the mitigation steps implemented by our technical teams and cache clearance by users, services appear to have been restored. We are currently awaiting customer confirmation of service stability.
We’ll continue to monitor the services for stability and will share the next update by Friday, 19 December 2025, 13:15 UTC or early as events warrant.
Posted Dec 19, 2025 - 09:28 UTC
Monitoring
A temporary workaround - clearing browser cache/cookies and following the additional steps shared by the DevOps team before accessing the application in a private/incognito browser session has been confirmed to restore access for affected users. No new errors have been reported. We will wait for client feedback tomorrow to confirm that the service remains stable.
We’ll continue to monitor the services for stability and will share the next update by Friday, 19 December 2025, 09:15 UTC or early as events warrant.
Posted Dec 18, 2025 - 18:06 UTC
Update
The technical team is analysing the logs to uncover the underlying cause of the issue. Initial observations suggest a possible session, cache, or SSO-related behavior.
We'll share the next update by Thursday, December 18, 2025, at 17:00 UTC or early as event warrants.
Posted Dec 18, 2025 - 15:31 UTC
Investigating
Users are unable to access the application URL. While the URL works as expected from internal checks, the users experiences an error message "401 Unauthorized" while attempting to login the application. The issue is intermittent and not consistently reproducible internally.
The technical team has been engaged and working to determine the underlying cause of the issue
We'll share the next update by Thursday, December 18, 2025, at 16:15 UTC
Posted Dec 18, 2025 - 14:19 UTC
This incident affected: Memotech (Memotech - MMT-D01, Memotech - MMT-L01).