Memotech Unavailable

Incident Report for Clarivate

Resolved

The application has remained fully operational during the monitoring since 08:58 UTC.

This is the final notification. This incident is resolved.
Posted Dec 18, 2025 - 09:47 UTC

Monitoring

Users may have encountered issues in accessing the application today, Thursday, December 18, 2025, between 07:48 to 08:58 UTC. Our technical teams have implemented corrective measures, and the application is now fully operational.

We'll monitor the services to ensure stability and will share the next update by Thursday, December 18, 2025, 11:00 UTC or earlier as events warrant.
Posted Dec 18, 2025 - 09:32 UTC
This incident affected: Memotech (Memotech - MMT-B03).